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A third-party fitness app does not function properly

A third-party fitness app does not function properly

Problem:

On Honor phones that support the pedometer function, a third-party health app does not count steps, counts steps inaccurately, or track the trajectory inaccurately.

Cause:

The app in question is stopped by your phone when it is running in the background.

Solution:

  1. Update your phone and app to the latest version.
  2. Do the following to prevent the app from being stopped when it is running in the background:
    1. Set the app to be allowed to run in the background:
      • Open Settings, search for and access Launch, turn off the Manage automatically switch for the app in question, and select Run in background in the prompt window.
    2. Verify that the app is ignored when the phone's battery optimization function takes effect:
      • Open Settings, and search for and access Ignore battery optimization. Touch the downwards arrow next to Don't allow, touch All apps, locate and touch the app, and select Don't allow.
    3. Go to Settings > Battery, and turn off Power saving mode and Ultra power saving mode.
  3. Go to the Recent tasks screen and lock the app in question to prevent them from being stopped when running in the background. To do so, swipe down on the app preview or touch the lock icon on top of the app preview, depending on the system version of your phone.

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