An app running in the background restarts when re-accessed
An app running in the background restarts when re-accessed |
Problem:
When the user re-accesses an app that has been switched to the background for a while, the app reloads and starts again. Sometimes, the user needs to log in to the app again.
Cause:
- To conserve battery power and mobile data, your phone automatically closes apps that have been running in the background for an extended period of time.
- When system resources are insufficient, your phone automatically shuts down some background apps to ensure optimal performance.
- To ensure data security, some third-party apps, such as some bank apps, automatically disconnect from the background and return to the login page after running in the background for a period of time.
Solution:
- To prevent an app from being shut down in the background, perform the following:
- Open Settings, search for and access Launch/App launch, disable the Manage automatically switch, enable Run in background in the dialog box that is displayed, and touch CONTINUE.
- Check whether Ignore battery optimization is enabled for the app.
- Open Settings, search for and access Battery optimization, touch the triangle icon, select All apps, find the app in question, and set it to Don't allow.
- To prevent an app from being stopped when you clear all background apps, lock the app preview on the Recents screen.
Open the app, access the Recents screen, then swipe down on the app preview to lock it.
Due to hardware resource limitations of entry-level devices, locked apps may still be cleared. This is a system protection mechanism. It is recommended that you clear background apps that are not frequently used in a timely manner to ensure sufficient system resources.
- Check regularly for system and app updates to ensure that your phone and apps are up to date. Back up your data before an update.
- If the issue persists, back up your data, restore your phone to its factory settings, and try again.