选择您的国家或地区: 停留在当前网站 请选择其他站点

荣耀商城
logo

我的荣耀 开启荣耀之旅

打开
App 内打开

荣耀手机/平板应用后台运行一段时间再次进入时会重新启动

适用产品:
手机,平板
系统版本:
Magic UI 6.1, MagicOS 7.0, MagicOS 8.0, MagicOS 7.1, MagicOS 9.0, MagicOS 7.2, MagicOS 8.1, Magic UI 4.0, Magic UI 5.0, Magic UI 4.1, Magic UI 6.0, Magic UI 4.2
荣耀手机/平板应用后台运行一段时间再次进入时会重新启动

问题现象

应用切换后台,过段时间,再次进入时应用会重新加载启动,有时还需要重新登录账号密码。

问题原因

  • 出于节省电量、节省流量的考虑,应用放置在后台一段时间后,系统会将其自动关闭。
  • 当系统资源不足,会触发清理机制清理部分后台应用,保障前台应用性能体验。
  • 部分三方应用为保护数据安全,后台运行一定时间会自动断开登录返回到登录页面,例如部分银行App。

解决方案

  1. 如果您需要此应用一直在后台运行的话,您可以将此应用设置为允许后台活动的应用,操作如下:

    进入设置搜索进入启动管理/应用启动管理,关闭应用的自动管理开关,并在弹框中勾选允许后台活动开关,点击确定,即可避免被清理。

  2. 允许应用忽略电池优化

    进入设置,搜索进入电池优化,点击小三角形,选择所有应用,找到该应用,设置为不允许

  3. 在多任务界面,给需要的应用加锁,操作方式如下:

    打开应用后,进入多任务界面,下拉选中的卡片进行加锁。

    内存较小的机型由于硬件资源限制,更容易出现加锁后的应用仍然被清理的现象,此现象为系统保护机制。建议及时清理不常用的后台应用,保证系统资源充足。

  4. 请您关注并及时更新系统和应用版本。
  5. 如果以上方法仍未解决您的问题,请您备份好重要数据,将手机/平板进行恢复出厂设置后尝试。

    进入设置 > 系统和更新 > 重置 > 恢复出厂设置,根据屏幕提示重置。

微信扫描二维码分享文章

谢谢您的鼓励!
您的意见已提交成功!

微信服务号

获取更多支持

热线支持
服务热线 95030
尊享服务热线 (折叠屏、至臻版专属) 400-00-95030
获取更多支持 获取更多支持
扫码获取更多服务资讯
微信公众号
微信公众号
扫码获取更多服务资讯
微博
微博
查看更多服务资讯
小程序
小程序
小程序
扫码获取更多服务资讯